Get in touch
Back
Maintenance

Domain Migration

Completed 14 Jan at 07:00pm HST.

Website
Completed

Maintenance completed

Posted 14 Jan at 07:00pm HST.
Started

During this migration our DNS might not resolve properly, causing late delivery of emails and not properly loading of the website WereldDigitaal.nl. This maintenance only impacts WereldDigitaal.nl

Posted 13 Jan at 10:55am HST.